Discussion

Left ArrowBack to discussions page
dgrdgr Posts: 3 Apprentice
Hello,
I'm using UR5 with 3.8 Polyscope with Polyscope set to Polish language (this setting is a culprit!).
I decided to update UCS 1.7.1 to newest version and I found a bug.
When I try to play program with Find Surface node I got following error.
Type error: rq_linear_search_urcap takes at most 5 arguments (7 given)
This error is related to Polyscope language settings. After changing to Int'eanglish this error disappeared.

Code with Polyscope set to Int eanglish:
   # begin: URCap Program Node
    #   Source: Robotiq_Force_Copilot, 1.9.0, Robotiq Inc.
    #   Type: Find Surface
    $ 7 "Find Surface"
    rq_ft_sensor_disconnected_check()
    surface_found = rq_linear_search_urcap("Z+",5,0.1000,0.1,1)
	$ 8 "'Add Stop conditions from the Command tab'"
    # 'Add Stop conditions from the Command tab'
    # end: URCap Program Node
Code with Polyscope set to Polish:
   # begin: URCap Program Node
    #   Source: Robotiq_Force_Copilot, 1.9.0, Robotiq Inc.
    #   Type: Find Surface
    $ 7 "Find Surface"
    rq_ft_sensor_disconnected_check()
    surface_found = rq_linear_search_urcap("Z+",5,0,1000,0,1,1)
	$ 8 "'Add Stop conditions from the Command tab'"
    # 'Add Stop conditions from the Command tab'
    # end: URCap Program Node
For some reason dot is changed to comma with Polyscope set to Polish.

Never had this problem with UCS 1.7.1.

Best Answer

Comments

Sign In or Register to comment.
Left ArrowBack to discussions page