Home Troubleshooting


Left ArrowBack to discussions page
Michael_DavisMichael_Davis Partner, Wrist Camera URCap 1.3.0 Posts: 4 Apprentice
We have seen this occur on a few different occasions now.  With UR software 3.4.1-59 and URCaps  UCG-1.1.1, there is roughly a 30 second pause/lag time between when the "Play" button is pressed and the robot program actually starting.  I wrote a simple program with a couple of Moves only and ran it with the URCaps installed, at which point the long lag time is there.  I removed the Gripper URCaps, made no other changes to the UR, ran the same program, and it started right away.  Has anyone else experienced a similar issue?  


  • abeachy_HG24abeachy_HG24 Posts: 79 Handy
    @Michael_davis I saw this on two of our URs, except one of ours lagged for almost a minute at times. To fix it all I did was uninstall the UR cap and then reinstall it, and it has been working ever since.
  • Michael_DavisMichael_Davis Partner, Wrist Camera URCap 1.3.0 Posts: 4 Apprentice
    I have done this a couple of times (uninstall, reinstall) with no change in outcome.
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,267 Handy
    I have not experienced that but will keep an eye out for it.  We currently only have 1 robot running with the robotiq URCap for the gripper.  It starts up in just a few seconds and we are running the latest firmware.  Hope that doesn't become an issue as this robot for various reasons has a lot of start of programs every day, generally 2-4 times an hour, 22-24 hours a day
  • Etienne_SamsonEtienne_Samson Beta Tester Beetle, Wrist Camera URCap 1.3.0, Vacuum Beta tester Posts: 419 Handy
    @Michael_Davis @matthewd92 @abeachy_HG24 I will keep track of this. @Michael_Davis do you see this happening with a specific program you are running or with every program you run? With large program it can be normal to have a delay between the play and the beginning of the program actually loading. It's simply linked to the robot memory and the size of your program. However 30 secs is a lot, personally never seen this.
    Etienne Samson
    Technical Support Director
    +1 418-380-2788 ext. 207
    [email protected]
  • abeachy_HG24abeachy_HG24 Posts: 79 Handy
    @Etienne_samson Whenever this was happening with us, it was not only when we would press the play button but all clicks were delayed. Not as bad as when we would press play, but at least 10 seconds or so and it did not matter what we were doing.
  • Michael_DavisMichael_Davis Partner, Wrist Camera URCap 1.3.0 Posts: 4 Apprentice
    edited May 2017
    Here is a video showing what has happened on a few different robots with programs of varying sizes.  As you will notice, this is a very simple program with only a few moves.  The URCaps has been removed and installed a few times now.
  • jamesjames Posts: 1 Recruit
    We are having this same issue on two of our URs. I have tried reinstalling Gripper UR Caps several times but to no avail. We have the same UR software 3.4.1-59 and UR Caps UCG-1.1.1. Has any solution been found?
  • David_LevasseurDavid_Levasseur Beta Tester Beetle Posts: 182 Handy
    @Michael_Davis , @james

    Hi Guys, I created a support ticket to track this issue. I will continue troubleshooting via this ticket and post back here when I have a solution.
  • David_LevasseurDavid_Levasseur Beta Tester Beetle Posts: 182 Handy
    edited June 2017
    This issue appeared after updating to the latest gripper URCap. Until we find the reason behind this behavior and fix it, if someone else encounters this issue, please contact [email protected] to get the previous working URCap.
  • JanKempeneersJanKempeneers Posts: 3 Recruit
    Hi, we seem to be experiencing the same issue with our UR10, the delay is not only when pressing play but can happen at any moment and is varying in duration. Also the URCaps menu is not working as supposed to, when clicking the arrow to open the menu a window seems to open briefly but disappears immediately.
  • StefanStefan Posts: 5 Apprentice
    I know it is already an old and closed thread but I have the same problem (Lag time between pressing "play" on UR and program start) with my UR10e and the URCap externalcontrol-1.0.1.urcap. This URCap allows to control the UR with ROS (https://github.com/UniversalRobots/Universal_Robots_ROS_Driver). After starting an external control program using the play button, it takes around two minutes before the program actually executes. Reinstalling the URCap did not help.

    I have already created a support ticket on the official UR developer forum on 16th of December but I have not received a reply yet. Does anyone know if my problem is just related with the external control URCap or might there be a different problem? Help would be very appreciated.

    Best regards,
  • StefanStefan Posts: 5 Apprentice
    I just wanted to let you know that I solved my problem. It turned out that the firewall UFW (Uncomplicated Firewall) was installed and active on my Ubuntu PC. I just needed to disable the firewall to get it working (sudo ufw disable).

    Now I can start my external control program and the connection to my ROS PC is established instantly. I can also start a ROS independent program without any lag. That`s great but it is also very strange that my firewall had such a big effect on the UR.
  • antbivantbiv Posts: 2 Recruit
    URGENT help required.

    Hello all,

    We too are running into the issue described by Stefan. We are using the External Control URCap to attempt to control the arm through ROS. However, we are not able to get past
    <pre class="CodeBlock"><code>`Starting Program: please wait...`
    on the touch pad for up to 15 mins before deciding to not wait any longer.

    We have tried to disable the firewall and reinstall the URCap, though these did not seem to help. We are able to get communication with the arm, however, the program time's-out waiting for a response from the program start.

    We would be grateful for any insight into similar cases and the solutions found.

  • sat_714sat_714 Posts: 5 Apprentice
    We are also having the same problem of a long time between pressing play and getting response from robot. Any help would be appreciated.
  • ziga004ziga004 Posts: 13 Apprentice
    Today, I've ecountered this issue as well with UR10e and the latest Polyscope version at this time. Yesterday everything was OK, I've not made any changes to the installation file, program or the Polyscope in general. Has a fix been issued? Thanks
Sign In or Register to comment.
Left ArrowBack to discussions page