Home Troubleshooting


Left ArrowBack to discussions page
simonb9simonb9 Posts: 1 Recruit
Hi, when I'm trying to close/open my gripper in my program, I get this error: "An error occurred in the running program": "Index out of range, the list size is smaller than 4". The script code crash at line 1953: while(rq_read_sta_req[index])

I was using this gripper on my UR10 earlier this week and it was working without any problem. I tried to use the gripper mounted on a wrist camera and without the wrist camera. I have updated my Polyscope version to the most recent versions, same for my gripper UR cap. I can use the gripper manually with the gripper Toolbar. I just cannot call URCap functions in my program like "Gripper Move50%" or script function like rq_move_and_wait(150).

Any suggestion what else I could try to fix this problem? Thanks for your help.

Best Answer

  • Yannik_MethotYannik_Methot Posts: 40 Handy
    Answer ✓
    For anyone wondering the cause of this issue: In this case, a global variable was named "Index" which was already used by our gripper URCap. Renaming this global variable to something else solved the issue.


Sign In or Register to comment.
Left ArrowBack to discussions page