Home Robotiq Products


Left ArrowBack to discussions page
sophvksophvk Posts: 2 Recruit
Hello, I am having the following issue with the Force Copilot:

I have a loop with four sequential force control commands. Sometimes the robot gets to the position and the loop works fine, some other times you can see that it accelerates too much, and eventually there's a "node executor error". It says to look at the log tab, but there's nothing related to the force copilot in there, no info at all about this issue.

I have tried several things:
 - First I tried one force control after the other, and added a wait(0.1) after each of them
 - Then I added a stopj(15) after each force control command
 - And then added a "Zero FT sensor" after each stopj(15), thinking that maybe that would fix anything.

It looks like this:

Each of the force control commands looks somewhat like this:

The changes in the four force control loops are basically in Rz, in direction and deviation angle. Also, Fz gradually increases in 5N.

I am using an ur16e, with polyscope 5.11.11. The Force Copilot URCap is version 1.25.0.

Any advices are helpful. Thank you!


Sign In or Register to comment.
Left ArrowBack to discussions page