Home Troubleshooting

Discussion

Left ArrowBack to discussions page
mohamedali1993mohamedali1993 Posts: 3 Apprentice
Hello, I am quite new to Linux/ROS and Robotiq. 

I am trying to install the Robotiq package from https://github.com/ros-industrial/robotiq

I am on Ubuntu 18.04, and I have ROS Melodic. I am trying to install this package for my Robotiq-E hand. I cloned the entire repository and ran catkin_make, and unfortunately, I had a lot of errors regarding dependencies, but I worked through them one after another. My last error that won't go away is:


-------------------------------------------------------------------------------------------------------------------------------------------------------------------------
CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find Protobuf (missing: Protobuf_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.10/Modules/FindProtobuf.cmake:543 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  /usr/lib/x86_64-linux-gnu/cmake/gazebo/gazebo-config.cmake:165 (find_package)
  robotiq/robotiq_3f_gripper_articulated_gazebo_plugins/CMakeLists.txt:7 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/bmvlab/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/bmvlab/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------




I tried to install Protobuf using: sudo apt-get install autoconf automake libtool curl make g++ unzip as mentioned on https://github.com/protocolbuffers/protobuf/blob/master/src/README.md

But this doesn't seem to help. I tried to also install the compiler on its own and again, I get the same error.

I am not sure if the system/Catkin is seeing the new compiler, do I need to add it to a certain path? to a system build file?

Any help will be appreciated! Please be precise in your answers, as again I am still a novice.

Thanks!

Comments

  • bcastetsbcastets Vacuum Beta tester Posts: 505 Expert
    @mohamedali1993
    I went through the same kind of experience.
    I would recommend that you first follow ROS tutorial before trying to install Robotiq package. It is important to understand how works packages before working with it.

    http://wiki.ros.org/ROS/Tutorials
  • mohamedali1993mohamedali1993 Posts: 3 Apprentice
    @bcastets thanks for the suggestion. I already went through all the beginner tutorials. I don't think that this has to do with Catkin setup, given that (to my knowledge) catkin uses a regular cmake compiler. It seems that the package is having problems with dependencies and/or pre-reqs. From my error message:
    robotiq/robotiq_3f_gripper_articulated_gazebo_plugins/CMakeLists.txt:7 (find_package).

    it seems that it can't find a certain package that would support the gazebo plugins. I believe that package is related to the protobuf. Would you please tell me what did you end up doing to get protobuf and install it with your setup?

    Thank you!
  • bcastetsbcastets Vacuum Beta tester Posts: 505 Expert
    @mohamedali1993
    I am sorry that we do not official support ROS installation and I don't have the answer to your question. Maybe someone from the community will be able to help.
  • mohamedali1993mohamedali1993 Posts: 3 Apprentice
    @bcastets either way, I appreciate your help. Thank you!
Sign In or Register to comment.
Left ArrowBack to discussions page