DoF - a Robotiq Community
Warning sign
The Dof Community was shut down in June 2023. This is a read-only archive.
If you have questions about Robotiq products please reach our support team.

Hello, I am quite new to Linux/ROS and Robotiq. 

I am trying to install the Robotiq package from

I am on Ubuntu 18.04, and I have ROS Melodic. I am trying to install this package for my Robotiq-E hand. I cloned the entire repository and ran catkin_make, and unfortunately, I had a lot of errors regarding dependencies, but I worked through them one after another. My last error that won't go away is:


CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
  Could NOT find Protobuf (missing: Protobuf_INCLUDE_DIR)
Call Stack (most recent call first):
  /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-3.10/Modules/FindProtobuf.cmake:543 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  /usr/lib/x86_64-linux-gnu/cmake/gazebo/gazebo-config.cmake:165 (find_package)
  robotiq/robotiq_3f_gripper_articulated_gazebo_plugins/CMakeLists.txt:7 (find_package)

-- Configuring incomplete, errors occurred!
See also "/home/bmvlab/catkin_ws/build/CMakeFiles/CMakeOutput.log".
See also "/home/bmvlab/catkin_ws/build/CMakeFiles/CMakeError.log".
Invoking "cmake" failed

I tried to install Protobuf using: sudo apt-get install autoconf automake libtool curl make g++ unzip as mentioned on

But this doesn't seem to help. I tried to also install the compiler on its own and again, I get the same error.

I am not sure if the system/Catkin is seeing the new compiler, do I need to add it to a certain path? to a system build file?

Any help will be appreciated! Please be precise in your answers, as again I am still a novice.