Home Troubleshooting

Discussion

Left ArrowBack to discussions page
tom24tom24 Unconfirmed Posts: 39 Apprentice
I have a problem with 5.9.3 ployscope froze up while in process the robot . it did not allow us to stop it and pause it. i appreciated for help full advice 

Comments

  • MSU89MSU89 Posts: 2 Recruit
    I also have the same problem with the 5.8 Ployscope (UR5e). The screen freezes in the process. Then it cannot be stopped either. The only option is to pull out the cable of the teach pendant, or to drive the robot down hard. We do not use a complex program, only 8 threads and few arithmetic operations. Simple pick and place tasks.

    I would be grateful for a short feedback.
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,171 Handy
    Make sure your threads are not overloading the controller. Depending on the task you are doing you may need to break it up and add a sync statement in your threads. Depending on the math for instance if you are doing heavy calculations or a lot of manipulation such as string manipulation it’s rather easy to overwhelm the controller. 

    Also, if you are logging messages to the log using textmsg make sure you are not sending them too rapidly as that will also overload the controller. 
  • tom24tom24 Unconfirmed Posts: 39 Apprentice
    Thank you Matt, The program is 1800 lines and I used one thread  to compare two CNC machines .  As  you said, I tried  using the  sync to break up the program but still froze up during the process .
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,171 Handy
    Its usually a thread that causes the issue, not the main program.  You can also try replacing your sync commands in the thread with a wait(0.01) or sleep(0.01) if you are using script to generate the thread.  That will reduce the load on the controller
  • tom24tom24 Unconfirmed Posts: 39 Apprentice
    Thank you, I will tested by adding a wait or a sleep
  • AdisharrAdisharr Posts: 5 Apprentice
    I'm running the 5.9.4 simulator and it locks up all the time even running almost nothing. UR seems to be becoming less stable all the time. I have to worry about using one in an application if it just stops for no apparent reason. When you can overload a controller by running an extra thread that's a huge issue.

    As I sit here now, I'm incrementing a variable by 1 with a wait statement after that. It ran once and now the simulator is completely unresponsive. Older versions have run just fine on both Win 7 pro and Win 10 machines. (VM VirtualBox)
Sign In or Register to comment.
Left ArrowBack to discussions page