Discussion

Left ArrowBack to discussions page
OBMOBM Posts: 2 Recruit
I have a robot running a simple pick and place program as part of a museum exhibition. The program runs fine, moves a box back and forth forever, but I am having trouble with the auto start function.

When autoloading a program not using gripper functions, the program will start and run fine. When loading a program with gripper commands, it will fail with the error-popup: “Program is not finished. Complete the yellow program-nodes in order to run the program.”

When i click OK on the popup and press play, the program will run fine.

During this, while the autorun fails, the status LED on the gripper flashes red, then switches to green. I suspect that the gripper somehow is not initialized before the program autostarts, and then by the time i manually start the program, it is. 

I tried putting in a wait in the beforestart sequence, and tried putting using subroutines for the actual program, but it did not work.
I was going to try a different approach using a script instead of a polyscope program, or maybe starting the robot from a remote computer using dashboard server. Not wanting to edit scripts on the teach pendant, or using dashboard server requires ethernet.

Unfortunately, when I connected ethernet, the gripper stopped working. Reports not detected in the UR-cap and no light in status light. Removing ethernet and rebooting, and the gripper comes back online. Does the gripper and the robot communicate via TCP/IP? I have been able to find some references to this and a “compute box” from OnRobot, but only in relation to using the gripper on a non-UR robot. 

I was kinda just handed this and told “make it work” - It han been fun programming and learning, but I’m kinda out of my league at this point, and any help or links to relevant resources would be very helpful :)

Comments

Sign In or Register to comment.
Left ArrowBack to discussions page