DoF - a Robotiq Community
Warning sign
The Dof Community was shut down in June 2023. This is a read-only archive.
If you have questions about Robotiq products please reach our support team.

I am working with a robotiq 2f-85 gripper and a TCP/IP controller box. When I power cycle the controller box but continue to send data, sometimes the controller box does not operate as expected.

1) My program sending TCP/Modbus messages disconnects because the controller box has lost power, but tries to re-connect periodically.

2) After the controller box is powered on again, I am able to send TCP/Modbus messages to, and receive TCP/Modbus messages from the controller box, but the green connection LED only blinks green, indicating that there is no connection. Furthermore, the messages I do receive are all zeroes, and if I try to set rACT, I still get a zero response. Also both the gFLT and kFLT fields are zero.

3) A few seconds later I get an error message when trying to read or write TCP/Modbus messages, saying "Connection reset by peer"

4) Another few seconds later, I am able to send/receive TCP/Modbus messages again with the same problems as described in 2), until the connection is reset again, and this continues in a loop.

In order to resume operation, I need to stop sending TCP/Modbus and either wait (not sure how long, it varies, 30 seconds to a few minutes) or power cycle the controller box (while no TCP/Modbus data is being sent).

When I send RS485/Modbus messages directly to the gripper I do not see this same behavior.

I have also tried connecting through the user interface. In the brief intervals between the controller box resetting the connection, I am able to connect, but again the green LED still indicates no connection and when I click activate, the gripper does not react. However, when I connect through the USB interface on the controller box I am able to connect and control the gripper.

I called the robotiq support and they claimed it's a networking problem because it works through the USB interface, but I have tested all of this with a direct connection between the gripper box and the computer.

This leads me to believe that it is a problem with the controller box translating TCP/Modbus to RS485/Modbus. Is this a known issue? Is there a fix? Any help would be appreciated.

Kind regards,