Home Troubleshooting

Discussion

Left ArrowBack to discussions page
matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,023 Handy
edited June 2016 in Troubleshooting
We are programming a new robot with the 2-finger 85 gripper on a UR3.  Everything has been working fine all week until just a few moments ago when we get the screen in the attached image.  The LED on the gripper is still blue, I have tried disconnecting it from the controller, rebooting the robot and neither has helped the issue.  Any ideas on what to try next?  

Best Answer

Comments

  • Etienne_SamsonEtienne_Samson Beta Tester Beetle, Wrist Camera URCap 1.3.0, Vacuum Beta tester Posts: 418 Handy
    Hi Matt,

    If you still have a blue LED then the communication is fine and it's probably a driver package issue. We know have package DCU-1.0.10 so you should update that first (we can see in your screenshot you have 1.0.9).

    Beside that, what's your Polyscope version ? Do you have any other package installed and/or devices ? (like the FT Sensor)

    Best,
    Etienne Samson
    Technical Support Director
    +1 418-380-2788 ext. 207
    [email protected]
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,023 Handy
    Etienne,

    I will have to look at PolyScope tomorrow when I am back with the robot.  Here's the weird issue, went to lunch and came back and it was working again.  Haven't had any more issues this afternoon.  I'll let you know should we see any other weird issues.  My only concern is this customer is 1000 miles from us so hoping once we are gone next week that he does not see the issue popping up since I do not know what actually fixed it.  I will do the firmware upgrade tomorrow as well
  • Kaleb_RodesKaleb_Rodes Founding Pro, Partner, Beta Tester VIsion 1.1 Program, Tactile Sensor Beta Testers, Beta Tester Camera URCap 1.2.0-beta Posts: 61 Handy
    Matt,

    Keep in mind that updating the robot software (polyscope) may cause changes or restrictions to functionality of the robot. Only update, if you can benefit from the new features or the fixed issues.

    Here is the release notes for the newest UR CB3 software update:  Version 3.2.21545

    I'd advise you to thoroughly read the release notes before doing an update, in order to avoid surprises, caused by changed or added functionality.

    Regards,
    Kaleb Rodes
    Applications Engineer
    Behco
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,023 Handy
    @krodes I completely agree with you about the upgrade. UR actually introduced new bugs in the 3.2.21xxx release that cause their own issues like overwriting files that have a similar name making it very hard to make a quick copy of a program to test a new feature in. This one bit us in the butt big time on our last install. There are some others as well that we have reported back to the development team in Denmark.  

    Fortunatley, the free drive issue that we have been experiencing on another worker was resolved with this release. That robot would just randomly decide to start missing a single point in the program. It occurred less than 5% of the time but we perform about 3000 cycles a day so some days we were missing as many as 150 times. 
Sign In or Register to comment.
Left ArrowBack to discussions page