Home Troubleshooting


Left ArrowBack to discussions page
PierreDenisPierreDenis Posts: 4 Apprentice
edited March 2018 in Troubleshooting

Hi pros,

I was programming 2 UR10, and one of theme use digitals I/O.

The problem here, is that all outputs stay at high level and I can't bring theme down.

If I touch an output it go low for around 0.1 second before go back at high level.

I've tried to force the outputs to low levels using the installation tab and choosing the "low when not running" parameter on all outputs. With this parameters up, we can see that something is trying to put the outputs at high level just before the parameter bring them down.

I've disconnected the 2-finger gripper (USB + alim), the network between the 2 UR, and every thing on I/O ports.

The 2 UR10 are on CB3.1 and up to date.

Here a short movie with the I/O tab : https://www.dropbox.com/s/slj8vhkblutwlhk/IMG_2358%5B1%5D.MOV?dl=0

Thanks for your responses.

Best Answer

  • PierreDenisPierreDenis Posts: 4 Apprentice
    Answer ✓

    I've solved my problem! Thanks to Loïc who is a DoF community member too.

    The problem is that I was using the port 1 on the Modbus, which is normally used to set the outputs, so this was effectively my Modbus which was putting all my outputs up.

    Thanks to Loïc I know now that I can use a port between 128 and 255 without any problems. All the other ones are reserved for something else.

    So, if someone use the address of the UR to communicate with it, remember to use a port between 128 and 255 in order to avoid any problem.


  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,267 Handy
    Have you tried removing all the IO blocks except the safety and power blocks to see if it stops? I’ve never seen an issue like this before. 

    One more ore dumb question....have you tried rebooting the robot?
  • PierreDenisPierreDenis Posts: 4 Apprentice


    All I/O blocks are removed but the problem is still here, like you can see in this short movie : https://www.dropbox.com/s/4f9jfeogdzflb34/IMG_2359.MOV?dl=0

    I've made my short program following these few steps, and I've made tests between each of them:

     - made a simple move -> OK

     - add I/O -> OK

     - add ModBus -> NOK

    I'll try to restart from the beginning but I'll add ModBus before I/O.

    And Yes I've reboot the robots, they where OFF for 2 days. When I try them this morning the problem was still here.

    I'm also in touch with a technical support, but for now, no solutions have been found.

  • PierreDenisPierreDenis Posts: 4 Apprentice

    I've just remade my program:

    I've start with a simple move from pointA to pointB -> no problem

    When I add a line in the before start section to put "255" on Modbus. The outputs start to blink (because they have still the parameter that forced them à low level when the program is not running)

    So I see here that the Modbus have effect on outputs for no reasons. And of course the Ethernet is not connected to the UR....

  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,267 Handy
    Can you post up your program?
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,267 Handy
    Here is a link to the UR documentation on the modbus registers on the robot and how to use them to access certain features that @PierreDenis mentioned.  


    These can be really handy, especially when you have multiple robots in a cell as one robot can see what the status of the inputs are on another one.  Very handy when you have more I/O on one robot than you have capacity built-in and another with excess I/O.  They can effectively use each other as modbus expansion systems.
Sign In or Register to comment.
Left ArrowBack to discussions page