Discussion

Left ArrowBack to discussions page
SebastienSebastien Posts: 214 Handy
Hi pros,
anyone know if it is possible to save programs on our plant network directly from the UR rather than saving on a USB stick? Could we also load the programs from the network?

Comments

  • matthewd92matthewd92 Posts: 508Founding Pro, Tactile Sensor Beta Testers Handy
    You could create a symbolic link within the programs folder to a different location on the corporate network.  I do this with the simulator, created a symbolic link within programs that points to the shared file location between the Linux virtual machine and my Mac
  • SebastienSebastien Posts: 214 Handy
    @matthewd92 do you know if it is possible to setup that symbolic link directly on the teach pendant? Or I guess we do this with the simulator and then transfer to the pendant afterwards?
  • matthewd92matthewd92 Posts: 508Founding Pro, Tactile Sensor Beta Testers Handy
    @Sebastien you can, you'd need a keyboard to enter the terminal of the robot but from there you can setup the symbolic link. Thats not something that would transfer from the simulator. 
  • SebastienSebastien Posts: 214 Handy
    @matthewd92 I see. I gave this a shot and I am not that good on Linux. I did map a folder that was in the simulators desktop to the programs folder of the UR simulator and it worked. However when trying to create a symbolic link that is pointing to something on the network I have a hard time. Do you need to 'mount' the network location first? If so what command line do you use to do this. I tried sudo mount but I get an access denied kind of error.

  • matthewd92matthewd92 Posts: 508Founding Pro, Tactile Sensor Beta Testers Handy
    @sebastien, not sure as I have never tried to do it.  Our robots are not sitting on a traditional network.  Maybe I will try with one of the ones in the lab when I am back in the office.  Here is some information I found on how to mount a network drive on another computer to the Linux machine using Samba, which I am not sure is included in Debian which is the version of Linux UR uses.  Also, if I recall the CB3 robots used a pretty old version of Debian, I have not looked lately to see what the newer machines are running.
  • SebastienSebastien Posts: 214 Handy
    @matthewd92
    sounds good. I will take a look at it and let you know if I find something that is working!
  • matthewd92matthewd92 Posts: 508Founding Pro, Tactile Sensor Beta Testers Handy
    Sounds good. Might be good to know when we are transferring programs from the simulator to production robots in the shop before deployment instead of using the trusty USB dongle
  • SebastienSebastien Posts: 214 Handy
    @PierreOlivier_Proulx
    have you done anything similar to this in the past? Saving programs on the network but being able to do so directly on the teach pendant of the UR?

  • PierreOlivier_ProulxPierreOlivier_Proulx Posts: 51Beta Tester VIsion 1.1 Program Handy
    I just tried to do it and I stumbled on a problem. The way I would have done it is to mount a samba share in the /programs directory with the command 
    mount -t cifs //<address>/<path> <mountpoint> -o username=<username>
    However, mount is telling me the cifs filesystem type is not supported. I investigated a bit and I found that the kernel module cifs is required in order to mount a samba share. There is two solutions for this (I think). First ask UR to distribute this kernel module. Second, compile this kernel module and load it on the robot.

    It could be a nice feature to package in a urcap.

    You can look at this page for a reference.

    Pierre-Olivier Proulx
    Software Designer
    poproulx@robotiq.com
Sign In or Register to comment.
Left ArrowBack to discussions page