Discussion

Left ArrowBack to discussions page
airmaxairmax Posts: 6 Apprentice
when i am teaching a circular movement with move-p the wrist #3 is turning in the other direction while running the programm than during teaching.

Comments

  • matthewd92matthewd92 Posts: 508Founding Pro, Tactile Sensor Beta Testers Handy
    Are you using a TCP other than the tool flange?  I had the same issue last year, never could figure out how to solve it so wrote my own function for the circle that I wanted in the program.  The program had a number of TCP's and if I recall if I only used the tool flange then it worked but otherwise it ran backward from how it ran when I stepped through the points.

    Has anyone else seen this?  
  • airmaxairmax Posts: 6 Apprentice
    Yes i am using a TCP that is different in orientation from the tool flange.
    I have also a problem with the orientation of the TCP.
    When i set the TCP orientation in direction to my robot z-axis it is different when i look at the plane settings.
    Could this be the issue?
  • matthewd92matthewd92 Posts: 508Founding Pro, Tactile Sensor Beta Testers Handy
    Was the plane taught using that TCP?
  • airmaxairmax Posts: 6 Apprentice
    I mean when i am looking at the plane settings i see my robot x y z - axis and my tcp x y z - axis.
    When i set the orientation of the TCP which should be done in direction of the robot base z - axis, the TCP z - axis is different in direction to the robot z - axis.
    In the program i use the Move-P with TCP and Tool setting.
Sign In or Register to comment.
Left ArrowBack to discussions page