Home Programming


Left ArrowBack to discussions page
LoïcLoïc Posts: 29 Handy
edited July 2017 in Programming
I have a problem of integration. We are using two UR10 piloted by a Siemens automate and Dashboard connection.
We call the program then we send the start command.
Our first problem was that we had to send the start command twice. We tried to delay the sending of the start command and it worked quite fine then.

But now, one of the two cobot doesn't want to start at all. We tried several things but the only way to launch the program is by the play button on the screen of the cobot.
The program is getting bigger but is not finished so it can be a real problem...

Did anyone have this problem before?
Does anyone have an idea or a solution to this problem?

Best Answer


  • LoïcLoïc Posts: 29 Handy
    Thanks Matthew, it's working with this update.
    I hope it will work when we'll finish this project because I've written only half of the program...
  • JacobBomJacobBom Posts: 11 Handy
    Previously (SW 3.2 and below), sending "load someprogram.urp" would return immediately, and then start loading the program. 
    Hence the program might not be fully loaded, when sending "play" a few ms later. Especially, if the program is rather big. 

    Since 3.3, the call only returns (e.g. "Loading program: someprogram.urp") after the program is successfully loaded. 
    Hence this might also be the issue, and resolves the problem, by upgrading to the latest 3.4.3.
  • LoïcLoïc Posts: 29 Handy
    I had the version and we had that problem with the start command. We updated the software to the and it worked well yesterday but today we had some problems again. As the client was here, we didn't have time to check what can be the problem. I'll update when I investigate more.
  • LoïcLoïc Posts: 29 Handy
    edited July 2017
    I realise that I didn't explain well what we're doing.

    We call the program via the Dashboard server. The robot answers well ("Loading program: <program.urp>").
    Then we set the input associated to "Start-prog", we see that the input turns On but the program doesn't start.

    This problem happens only after loading the program. If we set the "Stop-prog" and then set the "Start-prog", the program restart where it was. What is surprising is that it happens only on one UR10, the other works fine.

    Do you have any explanation?

    My next idea is to try to send the start with the command "play" via the Dashboard server, but as it's not the only "problem" that we have on this machine, I don't when we can try it...

  • LoïcLoïc Posts: 29 Handy
    Now we solved it. We wait some seconds before sending the start and it's ok. Thanks for your help
Sign In or Register to comment.
Left ArrowBack to discussions page