Discussion

Left ArrowBack to discussions page
mbarilmbaril Posts: 8 Apprentice

Has anyone been capable of establishing an Ethernet/IP connection with the virtual robot of URSim? I have a configuration where my PC is the Ethernet/IP Scanner.

I'm using the following parameters to connect to the robot:

Robot input size = 480

Robot output size = 224

Consuming connection point = 112

Producing connection point = 100

Configuration connection instance = 1

I was able to connect to a real UR5 using these configs, but It'll be great if I could use URSim for my developments...

Thanks for helping!

Best Answer

Comments

  • matthewd92matthewd92 Posts: 521Founding Pro, Tactile Sensor Beta Testers Handy
    So we do a lot of development with our TCP device from the simulator and getting a reliable connection from the simulator back to either the computer or our to the network can be an interesting challenge at first.  What system are you using for the simulator?  Are you running in VirtualBox?

    In VirtualBox if you just want to get to the host computer you can setup a host only connection in the network settings.  Then you would need to open the terminal and get the IP address that the DHCP server assigned to the robot.  Mine is usually 192.168.56.101 with my computer being 192.168.56.1 using the settings below Virtual Box (Access from preferences on Mac, not sure about Windows)





    And then on the actual machine settings you would choose host only and the adapter that you set-up



    If I want to be able to get to the robot or to another device on the network then I will usually use a bridged adapter that bridges the internet connection from my machine to the virtual machine.  Like I said we have used this to connect to robots from the simulator or to physical devices and the host computer for running TCP type connections.
  • mbarilmbaril Posts: 8 Apprentice
    Hi Matthew, thanks for your answer. Yes I'm using Virtual Box as my PC is Windows based. Actually, the first issue I have faced is that I can't even start the Ethernet/IP Adapter in the UR Graphical programming environment (Installation panel). The status remains "Not running" when I hit the "Enable" button, instead of "Adapter Running".  Do you have any idea why? Just to be clear, I'm trying to establish an Ethernet/IP connection (Implicit messaging using UDP instead of TCP) between the virtual robot controller and my windows application. Thanks again for helping!
  • matthewd92matthewd92 Posts: 521Founding Pro, Tactile Sensor Beta Testers Handy
    @mbaril Can you ping the Ethernet adapter from the virtual box terminal?  Can you access anything else on the network?  If that's possible then I'm not sure. I've never tried this but if you want to send me your Ethernet/IP application I'd be willing to see if I can figure it out. 

    Ill also see see if I can find an adapter on the web that I can try and connect to
  • mbarilmbaril Posts: 8 Apprentice
    Hi Matthew, regardless the network, my problem is that I can't even enable the EIP connection in the UR Graphical programming environment. I have been asking people from advance motion and they don't believe that what I'm asking for is possible for now. Thanks again for helping anyways!
  • matthewd92matthewd92 Posts: 521Founding Pro, Tactile Sensor Beta Testers Handy
    @mbaril just out of curiosity which simulator version are you running?  Are you saying that you cannot get the enable button to work?  Or it just never connects?  I am able to Enable it just don't have an EIP adapter to run on the host machine or our network anywhere.  This is in simulator version 3.3.2.266 which is not the latest, just the latest I have configured to run.



    @Stefan_Stubgaard do you have any feedback on this issue?
  • mbarilmbaril Posts: 8 Apprentice

    I have the same behavior as you have. I use URSim 3.3.3-292. I'm capable of toggling the enable button, but the satus of the connection never turns "running". The EthernetIP adapter is the robot, not the PC. If you have an EthernetIP Scanner on the host machine (which is my case), the status of the connection is supposed to turn from "running" to "connected".

Sign In or Register to comment.
Left ArrowBack to discussions page