Left ArrowBack to discussions page
DanielDaniel Posts: 9Partner Apprentice

Hi. Has anyone tried to or does anyone know how to remote control Polyscope, the user interface of Universal robots?

I’ve had the idea to install VNC server on a robot to be able to remote control the user interface. And now I can see a company already is selling it as a part of a product:


Does anyone know how to install VNC server on a UR robot?

Maybe it’s possible to install and set up VNC server using a magic script?

I know that by attaching a USB keyboard and by pressing <ctrl>+<alt>+<F2> you’ll switch interface to the Linux console. Maybe it’s possible to install VNC through this console? (pw: easybot) (Press <ctrl>+<alt>+<F7> to switch back to Polyscope.)

By installing VNC server it would be possible to remote control and troubleshoot a robot from office PC, tablet or smart phone... It could be quite useful.


  • mhowemhowe Posts: 28Partner Apprentice
    I have used the Airgate to VNC in to the UR. It is very easy to setup and connect too whether it be through your network or a mobile sim card. Never ran into any problems while using it.
  • lakshmip001lakshmip001 Posts: 30Partner Apprentice
    Hi Can I know how many robots can be connected to single Airgate  for communication.
  • lakshmip001lakshmip001 Posts: 30Partner Apprentice
    Hi, I want use Airgate for viewing and controlling  the Ployscopes of 2 or 3 robots. Can I know if i can use it? I went through the ARCS basic and ARCSrm . From I understood that ARCSbasic is used for getting sms alret while ARCSrm is for viewing the Ployscope. Does ARCSrm consist of ARCSbasic feature?? I don't get a clear understanding on ARCSrm. I would like to get help for ARCSrm. 

    Thanking you in advance.

    Warm Regards,
    Lakshmi Prasanna.
  • MarkEGuidaMarkEGuida Posts: 4Partner Apprentice
    edited March 15
    I work for a distributor of UR and AirGate.  We have the ARCS and RM both on our demo UR3.  The newest firmware allows for multiple devices behind the ARCS gateway device.  Meaning you can connect to other devices beside the UR from outside the LAN.  I do not believe you can set up multiple UR's automatically.  However, the ARCS is utilizing Secomea's GateManager appliance with a 5 device limit.  Therefore I could theoretically be manually configured to allow RM (VNC control of Polyscope) on more than one robot behind the same GateManager.  I have not tried this yet, but I might just throw our UR3 and UR5 in the same room and give it a whirl soon.  
    To answer your other question, the basic device (ARCS) is like you said, for getting system status messages sent to a phone.  The Remote Manager is an 'add-on' to this ARCS device....it's simply a software license to the hardware device.  So, short answer is NO you don't 'get' the basic functions of the ARCS with the purchase of the RM software license, you need to add it to your existing ARCS hardware.

    Clear as mud?

    I just realized that the link in the above post to the UR website is the article I was featured in.
  • PierreOlivier_ProulxPierreOlivier_Proulx Posts: 51Beta Tester VIsion 1.1 Program Handy
    @Daniel You can install VNC on a controller by issuing the command
    # apt-get install x11vnc
    You can access the console with the method you described in the first post.

    Once it is installed, you can use any vnc client to connect to your robot.

    I strongly suggest that you copy your UR controller flash drive before doing this. And make sure the copy is valid before doing it.
    Pierre-Olivier Proulx
    Software Designer
  • DanielDaniel Posts: 9Partner Apprentice
    Great! This is what I'm looking for.

    Have you tried this yourself? Does it work good?

    Do you have any tips on how to configure the VNC-server installation?

    And do you know if this is the command to uninstall VNC?
    $ apt-get remove x11vnc

    I could find this guide for x11vnc.

    Thank you for the tip.

  • PierreOlivier_ProulxPierreOlivier_Proulx Posts: 51Beta Tester VIsion 1.1 Program Handy
    @Daniel Yes I did. We used that method to cast our demo on a projector. The command I sent you is from what I recall though. There might be additional dependencies to install. If you have any issues just ask me.

    To remove it is the good command. But I suggest that you use your backup instead in order to restore your system to the factory settings.
    Pierre-Olivier Proulx
    Software Designer
  • DanielDaniel Posts: 9Partner Apprentice
    Hi, I made backup of USB-drive using ImageUSB and I was able to boot form a cloned USB3 drive. After some testing I was able to install and run x11vnc on a CB3.1 robot.

    Now I'm trying to make x11vnc service start automatically on system boot. Do you know how to solve this @PierreOlivier_Proulx ?

  • PierreOlivier_ProulxPierreOlivier_Proulx Posts: 51Beta Tester VIsion 1.1 Program Handy
    @Daniel Check the flie ~/xsession. This is a script that is executed when an X11 (GUI) is started. You can add a line to start x11vnc in that file. Check the options of x11vnc so it runs in background and continue to listen when a client closes the connection.
    Pierre-Olivier Proulx
    Software Designer
  • [Deleted User][Deleted User] Posts: 0 Apprentice
    I've been working on a VNC solution for the robots, thought I could as well share it with you guys:

    • Connect the robot to the internet and make sure it has an IP adress configured (DHCP/Static).
    • Connect to the SSH shell using putty (user:root / pass:easybot)
    • Run "apt-get update" and "apt-get install x11vnc". (I didn't want to break anything, so I didn't do an upgrade!).
    • Run "x11vnc -storepasswd YOURPASSWORD /etc/x11vnc.pass"
    • Edit ~/xsession as PierreOlivier_Proulx said, adding: "/usr/bin/x11vnc -xkb -noxrecord -noxfixes -noxdamage -display :0 -rfbauth /etc/x11vnc.pass -rfbport 5900 -forever -auth root -bg -o /var/log/x11vnc.log" at the beginning of the file (after the #!/bin/bash).This starts a x11 VNC server, with all the necessary options to make it run on background forever.

    I'm using UltraVNC Viewer to connect to the VNC server.

    Hope this helps some of you!

  • DanielDaniel Posts: 9Partner Apprentice
    Thank you for the nice summary! I was on my way on making one but you saved me the work.

    I also had to edit "/etc/apt/sources.list" and un-comment the two lines so the following servers are active:

      deb http://ftp.dk.debian.org/debian/ wheezy main contrib
      deb-src http://ftp.dk.debian.org/debian/ wheezy main contrib

  • [Deleted User][Deleted User] Posts: 0 Apprentice
    Daniel you're absolutely right, I forgot it.
    I can't edit my post anymore (they really should allow that!), but people will find out soon enough.
  • MarcelPMarcelP Posts: 2 Recruit

    Hello together,
    Thank you for the perfect explanation.
    Can one of you explain what I do wrong with my UR5?
    If I am on the Polyscope user interface, I enter [CTRL + Alt + F2] to get into the console.
    Then I log in with root and easybot.
    And if I then enter the command # apt-get install x11vnc ;it appears with me the message:
    E: Could not find package x11vnc

    So what am I doing wrong or are my steps the right one at all?
    Thank you

  • [Deleted User][Deleted User] Posts: 0 Apprentice
    Did you uncomment the lines in /etc/apt/sources.list' as Daniel mentioned?
  • MarcelPMarcelP Posts: 2 Recruit
    edited March 24
  • PretlousateurPretlousateur Posts: 1 Recruit
    Hi !

    Thank you for this solution, but i have a problem...

    When try this command : /etc/apt/sources.list'

    this message appears : -bash: /etc/apt/sources.list: Permission denied
  • PierreOlivier_ProulxPierreOlivier_Proulx Posts: 51Beta Tester VIsion 1.1 Program Handy
    edited May 25
    /etc/apt/sources.list is not the command. When you typed that, the shell tried to execute this file. Try this instead:
    nano /etc/apt/sources.list
    This will open a text editor so will be able to uncomment the lines.
    Pierre-Olivier Proulx
    Software Designer
  • woodchopwoodchop Posts: 1 Recruit
    edited May 25
    **nevermind -- editing the sources.list is the key**
    I've tried the above process (get update), the download site appears to be offline? 'failed to fetch http://packages.ur-update.dk/ubuntu/./Release.gpg'
  • jgentesjgentes Posts: 1 Recruit
    Daniel, you can remotely monitor, debug, and control the robot over the web using our cloud robotics platform: https://tend.ai.

    I'd be happy to answer any questions you have about how it works.
Sign In or Register to comment.
Left ArrowBack to discussions page