Home Programming

Discussion

Left ArrowBack to discussions page
Maximino14Maximino14 Posts: 3 Recruit
I am trying to use the command "socked_open" but it never works, I use this program on the robot UR3.



And the variable "open" never go to True, I used different IP address for the server and different ports but It never works.

I do not know if it some configuration that I need to do previous or what is the problem. the communication with the PC works because I use the command "ping with the IP address" on the "cmd" and everything works but the  "socked_open" does not works

Someone can help me!



Comments

  • Maximino14Maximino14 Posts: 3 Recruit


    It is the programming on the UR3
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,266 Handy
    What is the IP address of the computer you are trying to reach, the IP address you have in the screenshot above is the local host of the robot controller so not sure if anything is running at port 21?  Are you doing this on the simulator?  Can you use something like Socket Test to make sure you can connect to the source computer and port that the server is running on?
  • Maximino14Maximino14 Posts: 3 Recruit
    I used different IP address, it is only an example. 

    The real programming is:

    BeforeStart
    open≔socket_open(“182.178.1.80”,21)
    Loop open≟ False
    open≔socket_open(“182.178.1.80”,21)
    targetPos≔p[0,0,0,0,0,0]
    counter≔0

    And  IP address of the computer is “182.178.1.80”, also i test other like “182.178.1.85”, and the IP of the robot is “182.178.1.90”.

    The image of the programing of the robot is for a reference only, but is the same program the I have on the UR3
Sign In or Register to comment.
Left ArrowBack to discussions page