Home Integration

Discussion

Left ArrowBack to discussions page
pfgpfg Posts: 5 Apprentice
edited August 18 in Integration
Hello,

I'm trying to control a Hand-E gripper from an ABB robot with Ethernet/IP.

As template I used the EDS file available here:

In ABB RobotStudio the configuration of the device looks like this:


But there is an error relative to the Input Size and it doesn't work at all:

I tried other values with the same result.

If I set Input Size to 0, the outputs, and the gripper, are working.

These input and output sizes are a bit of a mystery to me as I would think the "correct" value is 16 (but it doesn't work with 16 for the output).


Does anybody have an idea what I'm doing wrong?

Thanks

P-F

Best Answer

  • pfgpfg Posts: 5 Apprentice
    Answer ✓
    Well, the "Maximum Input Size" of 24 bytes in the error message was no coincidence as it works with that value!
    Still strange as in the Robotiq User Interface the values are both 20 bytes:

    Here are the working settings:


Comments

Sign In or Register to comment.
Left ArrowBack to discussions page