Home Programming

Discussion

Left ArrowBack to discussions page
ZYFNOVZYFNOV Unconfirmed Posts: 3 Apprentice
I am trying to make a circle moving , teaching the TCP go through three points, but the moving closewise is fine, when try to make reversed moving, always got the error message said   "the blend radius is too small" . Did anyone know how to fix it?

Comments

  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,264 Handy
    We see the same issue from time to time, our general fix is to move the via point slightly.  We have reported this to UR as well as a bug since sometimes the points work and other times they do not
  • ZYFNOVZYFNOV Unconfirmed Posts: 3 Apprentice
    Thank you , Matthew. Just some updating, The most part of program works now, didn't change any waypoints location, seems the UR fix it by itself..  Another weird issue, the reversed moving cannot go to the end point which it is the  start point of  pathway . about 10 mm offset from the end point.  But the loop works, Just it cannot start the right location after 1st cycle. By manual , it is able to go to that point correctly. 
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,264 Handy
    That is why I think its a bug in UR, sometimes it works, sometimes it doesn't

    What blend radius are you using with the movep?  If you do not set the last point to have a blend radius of 0 it will move past that point to the next point once it is within the blend radius setting.
  • ZYFNOVZYFNOV Unconfirmed Posts: 3 Apprentice
    the blend radius is 15mm, and 25mm. The route is same.  For the forward , it is 15 mm, for the backward , it is 25. . All  three waypoints , Position are same.  I had tried to change 25 to 15, but it doesn't. work.  I have to create a new point for end points of backward path which is same as the start point of Forward path. To avoid the offset of endpoint of backward path.
Sign In or Register to comment.
Left ArrowBack to discussions page