Home Applications

Discussion

Left ArrowBack to discussions page
BobLaBobLa Posts: 4 Apprentice
HI guys,

I am currently having problem trying to connect the robot to Linux via Ethernet using the socket package in Python. This worked well with me before but after a week disconnecting the robot with Ethernet (I used the Ethernet portal on the laptop to connect to a camera for setting up and in the future I would want to use them both together) now it just does not work anymore??? I tried different methods from static IP (as in this link https://www.universal-robots.com/media/1226290/weiss_wsg_interfacing_universal_robots.pdf ) to using DHCP ( it will say connected to a network but the result will be 0.0.0.0 which is a very strange IP). A when I try the python code for those IPs, the code will return error of "connection refused" and I tried ssh into the robot but it also got rejected with the password easybot. However when I ping, it does work.

I am very confused right now and I hope that someone can have the answer for this strange issue with the robot

Thank you,
Bob

Comments

Sign In or Register to comment.
Left ArrowBack to discussions page