Home Programming

Discussion

Left ArrowBack to discussions page
bcastetsbcastets Vacuum Beta tester Posts: 237 Handy
From time to time we get questions about how to zero the Force Torque sensor on a TM Robot. Here below is some information that may help you if you when to do that.

First your will find a zero sensor option on each force control node. Here below is an example with touch stop node (ref: "Software Manual
TMflow" manual 1.76 2019-12-13):



There is also a way to access force sensor via script. TM script node have a a menu with some prewritten command. You can find some command for the force sensor. The "Expression Editor and Listen Node" manual which can be downloaded from TM website (you just need to create a user account) detailed force sensor script function and this include a zero sensor function.

Zero ON
FT[“fts1”].Zero = 1

From my understanding, if "FT[“fts1”].Zero = 1", the last sensor zero is used to compensate the value measured by the Force Torque sensor. An empty force node with a zero sensor check before the script command should be enough to refresh the zero of the sensor.

Here below is an extract of "Expression Editor and Listen Node" manual (2019-12-26). Please check the reference documentation for latest information.



The force torque sensor zero can be done manually using the force sensor menu in the left panel of TM Flow:



At the time of this article, I could not access a robot to make further testing. Please try the different solution on your robot to make sure think works as expected.

Here below is another article about how to work with TM force sensor data that may be interesting to check:

https://dof.robotiq.com/discussion/1865/tm-robot-how-to-stop-robot-using-ft300#latest

Comments

Sign In or Register to comment.
Left ArrowBack to discussions page