Home Integration

Discussion

Left ArrowBack to discussions page
KarthikKarthik Posts: 5 Apprentice
Hi All,

I am working on the Universal robot e-series(3e and 10e) with 2F gripper(2F-85) with the latest ROS driver(Universal_Robots_ROS_Driver). Not the old ur_modern_driver.
With Ubuntu 18.04 and ROS Melodic version. The robot is controlled with Moveit! package and I am able to control the robot's position and perform path planning.
I need to control the gripper(activation, open, close, reset) through ROS from the robot.  I found that it can be controlled when the gripper is directly hooked into a computer. But I need it to be controlled from the robot the way it is done with the URcaps. Is there a way or if anyone can direct me how to proceed with, that would be helpful.

Thank you
Karthik

Comments

  • EnzoEnzo Posts: 1 Recruit
    Hello Karthik, 

    There's a guide about this in the Universal Robots ROS Driver here
    Then I believe you should be able to control the 2F-gripper the same way as when it is directly hooked to your computer.

    I haven't tried it yet but will be doing so next week. 

    Let me know if you manage!

    Enzo,
  • KarthikKarthik Posts: 5 Apprentice
    Hi Enzo,

    Thanks for getting back!

    Yes I did follow that guide but wasn't sure how to activate the gripper as there is no driver for Robotiq with wrist socket. Some people reported that the Robotiq driver is compatible only with the wired connection and not the wireless socket on the wrist. Is there any link which shows how to do the setup or has anyone done it? I'll give it go anyways.

    I am also trying to use the URscript commands to control the gripper. It isn't working either.

    Have you or anyone worked with the urscripts being sent from a computer?
  • BobLaBobLa Posts: 4 Apprentice
    Hi Karthik or anyone that see this,

    I know it've been quite a while since this discussion but I am facing the same problem as you right now, so may I ask have you found a way to control the Gripper via ROS ?? The robot I am working right now is UR5e.
    I have successfully found a way to control the Gripper along with the robot via the URScript by sending the commands via socket on Python. It worked but I still want to control it via ROS! Plus, I wanna know how to show the gripper and control it in a stimulated environment as well (such as on Rviz)>

    Thank you
    Bob
  • felixvdfelixvd Posts: 6 Apprentice
    I forked a fork of a robotiq driver and wrapped it [here](https://github.com/felixvd/robotiq/tree/add-urcap-socket-interface), but I never documented or really published it (shame on me). If anyone wants to clean it up and push it upstream, be my guest.
Sign In or Register to comment.
Left ArrowBack to discussions page