Home Integration

Discussion

Left ArrowBack to discussions page
MatthiasMayrMatthiasMayr Posts: 4 Apprentice
Hi!

There are posts that suggest that the 3 finger hand can be simulated in Gazebo [1].
However if I start the shipped launch file
mon launch robotiq_3f_gripper_articulated_gazebo robotiq_gripper_empty_world.launch
I only get empty world in Gazebo with an non-moving hand. I am missing the step where I can control the hand in any way.
The only additional topic I get is 

/robotiq_hands/left_hand/joint_states
but it also doesn't publish anything.
According to the Atlas tutorial it looks like there should be additional nodes for the state and commands [2].

What am I missing? I can't find additional executables or launch files in the Gazebo packages.

Technical details:
This is with Ubuntu 18.04, melodic and Gazebo 9.0. I cloned the ros-industrial/robotiq repo today.







Comments

  • romyalromyal Posts: 5 Apprentice
    edited September 2019
    Hi MatthiasMayr,

    Good question!

    Did you launch all the files in the Robotiq_3f_gripper package? Please see attached screenshots of what you need. You can access these files here: http://wiki.ros.org/robotiq.
    You can also find installation procedures here: https://github.com/ros-industrial/robotiq.

    Keep us updated if any progress comes up :) !





  • MatthiasMayrMatthiasMayr Posts: 4 Apprentice
    edited October 2019
    Thanks for the reply. I followed the instructions in the ROS wiki to work with the actual gripper we have. That worked well and was straight forward to do.

    It would be great if the documentation would feature, how to actuate the gripper in simulation. It is neither mentioned in the ROS wiki nor in the ros-industrial repository.

    I am also unsure what you mean by "Did you launch all the files in the Robotiq_3f_gripper package?" The only other launch files there existing in the repository are either already included in the "robotiq_gripper_empty_world.launch" or seem to be the communication launch files ("robotiq_3f_gripper_can.launch" and "robotiq_3f_gripper_ethercat.launch")


  • MatthiasMayrMatthiasMayr Posts: 4 Apprentice
    Thanks for your reply. I followed the instructions you mentioned to get the real gripper to work.

    I haven't found instructions to use it in simulation though, neither in the ros-industrial repo nor on the ROS wiki pages. It seems that there are people out there who made it work, but I haven't found instructions from anyone.

    I am unsure what you mean by "Did you launch all the files in the Robotiq_3f_gripper package?". The only other launch files I can find are either already included by the
    robotiq_3f_gripper_articulated_gazebo robotiq_gripper_empty_world.launch
    that I launched or they are for real communication like "robotiq_3f_gripper_can.launch" and "robotiq_3f_gripper_ethercat.launch".





  • bcastetsbcastets Vacuum Beta tester Posts: 176 Handy
    Dear  MatthiasMayr,

    At the moment we have no instruction to simulate our gripper on Gazebo.
    I think some persons did it but we don t have instruction from our side.
    Maybe someone from the community will be able to share its experience.
  • MatthiasMayrMatthiasMayr Posts: 4 Apprentice
    Hm, that's a bit disappointing taking into account that ROS support is explicitly advertised:

    Here are the different packages which allow you to control the 3-Finger Gripper and simulate it using the Gazebo simulator which is commonly used with ROS:

    • Articulated Gazebo (robotiq_3f_gripper_articulated_gazebo & plugins) — Loads up the articulated model of the gripper into an empty Gazebo simulation.
    [...]

    With the new package, you can really get a grip on the functionalities of the 3-Finger Gripper!





  • bcastetsbcastets Vacuum Beta tester Posts: 176 Handy
    Sorry indeed we have some tool for that.
    I recommend you send your question to [email protected] the person in charge will answer your questions.
  • lms95lms95 Unconfirmed Posts: 2 Recruit
    Hi, I am sorry if it is not adequate to refloat a post.

    I have been working on a robotic simulation of a UR arm with one of the Robotiq grippers. First I tried to simulate the robot system in Gazebo with a 2f_85 attached to the arm. However this configuration led me to lots of errors while simulating. As I have investigating it's a common error and there are several questions in this forum regarding that topic. It seems that the base of the gripper does not work well in Gazebo despite that it does work well in Rviz. So instead giving up and going for the non-official packages for example StanleyInnovation or Beta-Robotics packages that seem to work well, I tried to simulate the 3 finger hand.

    I have been tweaking the official URDF files of the hand in order to add the <transmission> tags that I was not able to find. Indeed I am able to load the hand in Gazebo, I have created the correspondant .yaml controller file. But, when the simulation loads the hand wobbles a lot. I've trying to tune up the pid gains (since I decided to use a effort_controllers/JointTrajectoryController type), but with no luck. The hand does not stop wobbling. The thing is that all the topics and services seem to be OK, I can start a Joint State Controller in Rqt but the hands continue to shake.

    I was wondering if it is due to the damping, mass or inertia of the links. I'm almost sure that the pid gains has something to do with that. But I have looking to the controllers of another similar hand gripper package and the controllers are not as detailed as mine. Do you have any idea of adequate values for my case?

    Thank you anyway!
  • MarcAntoine_GauthierMarcAntoine_Gauthier Vacuum Beta tester Posts: 33 Handy
    Hello @lms95,

    Sorry for the delay. I had to gather some info before answering you.

    First, don't worry about commenting older post, it is always good to continue a discussion if it is needed.

    For your inquiry, unfortunately the visualisation package that are used in Gazebo were not contributed by Robotiq. It has been done by the community. Therefore, it is not something we support or help troubleshoot.
    Same thing with your PID, it is really hard for us to suggest or recommend values since it is not something we have created.

    I am sorry for the inconvenience that it could cause you.
    Hope you will be able to make it work!

    Regards.
  • lms95lms95 Unconfirmed Posts: 2 Recruit
    Don't worry.

    I was playing around with the gazebo simulation. Finally I decided to go with one of the packages that seems to work of the Robotiq 2f 85 gripper. When I have more time I will try to solve the problemes changing the effort_controller to a position controller which I think does not need the PID values.

    Thank you anyways!
Sign In or Register to comment.
Left ArrowBack to discussions page