Discussion

Left ArrowBack to discussions page
SebastianSebastian Posts: 6 Apprentice
Hey guys,
I ran into a problem regarding the movel command from the URScript, and I could not find a similar question in this forum. I am trying to rotate the robot around the front tip of the FT300 gripper as explained in the following picture, but it just does not work:

My python code looks like this: 
pose_movel = pose_trans(get_actual_tcp_pose(), p[0,0,0,0,c.deg_to_rad(10), 0)
set_tcp(p[0,0,0.225,0,0,0])
movel(pose_movel, a=.02, v=.01, t=0, r=0.0)
set_tcp(p[0,0,0,0,0,0])

The robot moves in a very unexpected way, as if the new TCP frame is set somewhere different, but I cannot figure out why. The distance between the original TCP point and the red dot on the image above is 22.5cm. I also tried to set the first set_tcp_before the pose_movel variable, but it still did not work. What am I doing wrong here?

Best regards
Sebastian

Comments

  • matthewd92matthewd92 Posts: 966Founding Pro, Tactile Sensor Beta Testers Handy
    I think you need to set the TCP before you do the math, try moving the set_tcp ahead of the pose_trans.  That is where we place the tcp and do this quite frequently
Sign In or Register to comment.
Left ArrowBack to discussions page