Discussion

Left ArrowBack to discussions page
kuba8kkuba8k Posts: 5 Apprentice
Hi,

I'M trying to use Wrist Camera to recognize colour of the cube and drop it to proper box. When I'm teaching Camera Locate function everything seems to be ok. It can find most of the cubes. When I save the settings and open the test/modify option it most often comes with error CL 120. During the work Wrist Camera just does not find the cubes (On 60 tries just 2 or 3 different cubes).

Anyone have met with something like this? 



Tagged:

Comments

  • Nicholas_FrancoeurNicholas_Francoeur Posts: 35Wrist Camera URCap 1.3.0 Handy
    edited October 30
    Hello @kuba8k,

    What version of the Wrist Camera URCap are you using? The latest release will let you adjust the threshold of the color validation, thus it will not be a simple pass or fail as in the error you're getting.

    The latest release also has a color view which will allow you to preview which colors will be used to build the signature color of the model.

    Try this and let me know if you have other questions.
  • kuba8kkuba8k Posts: 5 Apprentice
    Hello @Nicholas,

    I'm using Wrist Camera URCap 1.6.5.
    In Troubleshoot there are many settings of camera. Is this possible to change and save them?
  • Nicholas_FrancoeurNicholas_Francoeur Posts: 35Wrist Camera URCap 1.3.0 Handy
    @kuba8k

    No it is not possible to save any parameters from that menu. This is simply used for troubleshooting.

    How does the cubes look like when you use the color view? You can access that view by pressing the "Eye" button, that is located at the top right, twice.
  • kuba8kkuba8k Posts: 5 Apprentice
    edited October 30
    @Nicholas,

    now i'm getting Error CL3 all the time, so it's hard to tell or make a photo. Uninstalling vision server does not change anything. 
    So, it is anyhow possible to change exposure, brightness or contrast? 

    EDIT,
    photo added,
    Green and blue looks ok. One yellow looks like white. 2 oragne like yellow. 
  • Nicholas_FrancoeurNicholas_Francoeur Posts: 35Wrist Camera URCap 1.3.0 Handy
    @kuba8k

    Remember that color validation is used as a second validation after the edges validation. It is currently only considering a color signature that has 10 different colors. It is then possible that similar colors, or some that are close in the color spectrum, are seen as the same color by the validation algorithm.

    Try turning on or off the Wrist Camera LEDs and see if that helps.
  • kuba8kkuba8k Posts: 5 Apprentice
    I'm trying different configuration. And for now it's not enough. It's hard to get perfect light to let camera see colours what they really are. 
    It can be easier if i can change some settings. But focus and LED are not enough. Especially when yellow and white are for camera nearly the same. 
    And i found something weird. 
    After i teach camera, for example green colour i save settings and right after that i open test/modify. The camera cant find anything. Then i switch multiple selection to 2. Camera can find 2 pieces. After that i switch to 1. Camera again can find a piece. Now i save it -> test/modify. Camera cant find anything again. 
  • Nicholas_FrancoeurNicholas_Francoeur Posts: 35Wrist Camera URCap 1.3.0 Handy
    @kuba8k

    That means that either the edges or the color validation failed. 

    Make sure you test your parts at different places in your field of view. Adjust the thresholds accordingly and make sure that the color signature used represents all locations.
  • kuba8kkuba8k Posts: 5 Apprentice
    I don't get it. Camera can't find one piece, but searching for two is ok? 
    Few moment ago i taught Camera green cube. During teaching it goes with Edge score 97 and colour score 95. Threshold for edge i leave on 60, threshold for color on 85. I don't change any position or anything and camera does not find anything during program run.  

    During the program run, i'm opening Installation -> Camera and offten get Error CL3? What does it mean?
  • Nicholas_FrancoeurNicholas_Francoeur Posts: 35Wrist Camera URCap 1.3.0 Handy
    @kuba8k

    This does not look like normal behavior. You should contact Robotiq's Support Team to log those bugs.
Sign In or Register to comment.
Left ArrowBack to discussions page