Home Programming

Discussion

Left ArrowBack to discussions page
matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,131 Handy

In version 3.6.1 and 3.6.0 we will be working on testing simple pieces of code and so we will create a new program with just a couple of lines of code. We store our work in progress programs in a folder and so when we create these small programs if we just hit play before saving them the system switches from the currently loaded installation to the root level default installation file. It used to ask if you wanted to load the current programs installation or use the currently loaded one at which point I’d just choose to run the currently loaded one and change the program to match. Once we saved the program into the current working folder then it would stop asking about switching installation files.

What happens now is it switches to the root level default installation and turns the controller off. This causes issues obviously and not the least of which is potential lost work if you have made changes to the installation file and have not saved it prior to hitting play.

Anyone else experienced this? We have seen it on every robot running 3.6.0 and 3.6.1


Comments

  • louis_bergeronlouis_bergeron Posts: 94 Handy
    @matthewd92

    I did this test here and I got the same result.  I noticed that if I don't power it on right away and use the Exit button, the program and the installation file are still there with the modification I did.  But we must be aware of it and thanks for this notice.


    Louis Bergeron
    Integration Coach
    robotiq.com
    [email protected]
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,131 Handy
    @louis_bergeron I did hear from JBM at UR and he's saying this was covered in the release notes and is part of new functionality where the installation of the program you are loading is automatically loaded without asking if you want to change from the currently installed installation.  Not sure about you but feel that for a new program I would prefer for it to use the currently loaded installation, this is really only an issue when you use folders for work as we do since it grabs the installation file out of the root folder.

    Opinions?
  • EnricEnric Founding Pro, Partner, Beta Tester Multi Gripper, Vacuum Beta tester Posts: 112 Handy
    This week I have seen something similar. We have the URs with V3.6.1 and all the URCaps of Robotiq and Skills in our Showroom. with the clients. Tomorrow I will look at the problem, but I agree with you @matthewd92.
    Enric Vila Avila
    Vicosystems S.L.L.
    Industrial Collaborative Systems

    [email protected]
Sign In or Register to comment.
Left ArrowBack to discussions page