Discussion

Left ArrowBack to discussions page
pgb123pgb123 Posts: 12 Apprentice
Probably a simple/dumb question, been looking all over the web and can't seem to find

Best Answer

  • pgb123pgb123 Posts: 12 Apprentice
    Accepted Answer
    Actually we've got all the commands, but using the latest driver from the Robotiq support page, the gripper interface loads up on the PC, but says it can’t connect, have tried all combinations of the IP address and ports such as 192.168.1.10 (this IP is working fine from python to connect to the robot), 127.0.0.1 and with and without port 63352 to no avail, says can’t find gripper.

    The robot itself is working fine from python and the gripper works fine from the teach pendant.

    I suspect the gripper is not the current model, but how can we get the version number so we know which of these to use? https://robotiq.com/support/archive 

    Have gone into Polyscope>Installation>Gripper>About and it doesn’t say but it does say at the bottom Robotiq copyright 2016 

    Has anyone tried this on a UR3 (as it says it's only been tested on UR5 and UR10) https://github.com/SintefRaufossManufacturing/python-urx

    Hopefully some kind sole here can lend us a hand?

Comments

  • sennrobosennrobo Posts: 2 Recruit
    Looking forward to any info on this as well. Trying to write a simple initialization script through the RoboDK Python API. 
  • PierreOlivier_ProulxPierreOlivier_Proulx Posts: 68Beta Tester VIsion 1.1 Program, Vacuum Beta tester Handy
    To see if you can communicate with the gripper through socket from another PC try those commands (you might have to install netcat i.e. nc):
    > nc <robot-ip-address> 63352
    > GET ACT
    > <should return ACT 0|1>
    If you can move the gripper from the teach pendant, those commands should work. If not, it is likely a  network issue as the port 63352 is exposed to other devices
    Pierre-Olivier Proulx
    Software Designer
    [email protected]
  • EmilianoEmiliano Posts: 1 Recruit
    edited May 2018
    We had the same issue recently. We had to upload a script provided by Robotiq. I've attached the file in a zip the Robotiq supplied us with. This is the method that we used to do this to point you in the right direction. There's also sample Python scripts in the zip file that could help as well.

    For a little more information the way this works is that the Teach Pendant loads it's own drivers which the standard Robotiq install covers. This is why the gripper works in teach mode. Unfortunately it seems like this driver is not installed globally so the Python script doesn't have a driver to work with. This script uploads it. We did it on initialization of the class.

       def _initialize_gripper_with_script(self):
    """
    Sends the script to run the Robotiq 140mm gripper to the UR robot. This is needed to run the gripper via
    sockets. This is best run at the initialization of any script that may use the Robotiq gripper.
    :return: None
    """
    s = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
    s.connect((self.host, 30002))

    f = open(os.path.dirname(os.path.realpath(__file__)) + "/from_robotiq/Gripper.script", "rb") # Robotiq Gripper
    # f = open ("setzero.script", "rb") #Robotiq FT sensor

    l = f.read(1024)
    while l:
    s.send(l)
    l = f.read(1024)
    s.close()
    f.close()
    sleep(1) # make sure gripper has time to initialize.




  • albertgoalbertgo Posts: 5 Apprentice
    After uploading the script, how do you communicate with the gripper and send commands?
Sign In or Register to comment.
Left ArrowBack to discussions page