Home Programming


Left ArrowBack to discussions page
tianxiangtianxiang Posts: 6 Apprentice

I installed the URCap. I can activate, open and close the gripper (2 finger 85) on the toolbar. But when I put "rq_reset()" in a UR teach pendant program and try to run the script, it is stuck there forever (showing a blue arrow to of left of rq_reset()) and never go to the next line. What could be wrong?



  • David_LevasseurDavid_Levasseur Beta Tester Beetle Posts: 182 Handy
    Hi @tianxiang, put the scrip code rq_activate() or rq_activate_and_wait() after the reset
  • tianxiangtianxiang Posts: 6 Apprentice
    Hi David and other experts,

    Thanks for the quick response. I very much appreciate it. I tried, but doesn't seem to solve the problem.

    I attached my simple script below. The gripper opens and closes 10 times as it should be during the Loop. But once outside the Loop, it passes rq_init_connection(), then again struck in rq_reset(), never goes to rq_activate_and_wait(). Any other idea?

    BTW, where can I locate that rq_reset() script? Never been able to find it anywhere...


  • tianxiangtianxiang Posts: 6 Apprentice
    Ah, so seems I need to do rq_reset(2). Seems like if I don't have the number inside, the default is 1, my gripper is at 2. now it is solved.
Sign In or Register to comment.
Left ArrowBack to discussions page