Home Programming


Left ArrowBack to discussions page
ChrisBRChrisBR Posts: 1 Recruit

I need some assistance with a UR10.

I would like to offset the program in X, Y and Z which works fine when I transform the BASE_VAR, but when 

modifying the program the coordinates references back to BASE instead of BASE_VAR.

See example description below:

-          In my initial program my BASE_VAR is 0 and my X coordinate is 20mm.

-          I now change the BASE VAR to 20mm and my robot moves the additional 20mm.

-          When I modify this waypoint while in the offset position without moving the robot, the value X-Value for my waypoint

changes to 40 and does not stay at 20 because it is referencing back to BASE and not the offset BASE_VAR.

Is there any way of getting around this problem, I need to be able to reference my coordinates to the BASE_VAR and 

not the base when teaching the robot.




  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,171 Handy
    I believe you will need to transform your points using the BASE_VAR before using them.  I worked around with this a couple years ago and seems like moveL worked without the transform but moveJ had to be transformed first.  

    I just checked in the simulator and a moveL  and moveJ will reference BASE_VAR not BASE when the variable box is checked on the BASE Feature, this is using version 3.8 URSim.  What version of Polyscope are you running?

Sign In or Register to comment.
Left ArrowBack to discussions page