Home Troubleshooting


Left ArrowBack to discussions page
Has anyone seen any weird bugs after updating the UR software to the latest version, 3.4.1-59?


  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,060 Handy
    Define weird....what are you seeing?
  • abeachy_HG24abeachy_HG24 Posts: 79 Handy
    After I updated to the latest software I had two weird things happen. The first thing that happened was I left Friday afternoon and the UR was working just fine, Monday morning I went to run that UR and the two pallet wizards and a handful of other waypoints were off in the x and z by roughly 3 mm in each direction. These waypoints are programmed to the base, and do not reference any planes or anything like that. It seemed like someone came in and went through a whole bunch of points and manually changed them, but I checked our security cameras and that is not the case.

    The second thing that happened was the UR was running the program and the robot randomly tried to go to the home waypoint. I watched it run some more cycles without it happening again, and then later as I was watching it I was able to see it happen. The UR was in the middle of its cycle and the program essentially restarted itself from the beginning of the program without anyone doing anything to it. The program pointer was in the before start sequence and it was attempting to go to the home waypoint but it crashed on the way there. I have seen this happen on three separate URs a handful of times and they are doing completely different operations with different programs. On the other two URs it picked the first part and then placed it, and after it placed the part it went home and then went to pick another part and crashed when it tried to place the second part on top of the first part. We are not using the I/O to start the program at this time.
  • Etienne_SamsonEtienne_Samson Beta Tester Beetle, Wrist Camera URCap 1.3.0, Vacuum Beta tester Posts: 418 Handy
    @abeachy_HG24 I had personnaly experienced the bug you had with the pallet wizard, but that was last year on polyscope 3.1. I found out at that time that doing copy-past of waypoints inside the pallet wizard would give me some really strange things. Since then I had nothing like this. If I hear anything about this I will let you know.
    Etienne Samson
    Technical Support Director
    +1 418-380-2788 ext. 207
    [email protected]
  • matthewd92matthewd92 Founding Pro, Tactile Sensor Beta Testers Posts: 1,060 Handy
    We haven't seen anything like that. We've seen a bug since upgrading to 3.4.0 and 3.4.1 where it gets stuck on the initialization screen, only way to get off is shutdown. That seems to be fixed in 3.4.1 as we've only seen it once in one reboot immediately after the upgrade. 

    Theres been rent a couple of other minor GUI bugs but I'd have to go back through our reports to recall them. 
  • abeachy_HG24abeachy_HG24 Posts: 79 Handy
    @etienne_samson In this situation I hadn't copy and pasted any of the pallet wizard stuff. It was just completely random. It seems really odd to me have it was off, but it was only some of the points in that robot and not all. Thanks, I appreciate that. 

    @matthewd92 I never saw that bug. These two things are the only things that I have seen that could possibly be bugs. Otherwise the software update has been working great. 

    We've been in touch with UR concerning these two things and they don't seem to have any answers yet. Just thought I would take a shot and see if anyone else was having weird or random bugs like this. If I find out any new information, I'll be sure to pass it along to everyone. 
Sign In or Register to comment.
Left ArrowBack to discussions page