Discussion

Left ArrowBack to discussions page
wukongwukong Posts: 3 Apprentice
When I connect the gripper to Linux(14.04) via USB(serial  to USb), I can't find any ttyUSB, but the LInux have already installed the FTDI driver. I need your help.

Comments

  • carlosjosergcarlosjoserg Posts: 18Tactile Sensor Beta Testers Handy
    Hi @wukong

    Could you be more specific about the ROS distro you are using, what driver (link to a repo), if you are compiling from source or installing from binaries, what gripper (2 or 3 fingers), steps you have done so far, so the help would be more accurate?

    Best
  • wukongwukong Posts: 3 Apprentice
    Hi@carlosjoserg ,
    Thanks for your reply!
     My ROS distro is indigo, and the repo link is https://github.com/StanleyInnovation/robotiq_85_gripper, and the gripper is robotiq 2 finger(85). I connect the gripper to Linx via the USB of the gripper and camera supplied by robotiq company. And I run the driver node, the wrong is happened as below.
    And actually after I load the USB, the Linux can't find any USB devices.
    BEST

  • carlosjosergcarlosjoserg Posts: 18Tactile Sensor Beta Testers Handy
    Ok, thanks for the info @wukong

    First, when working with Robotiq ROS package, I'd suggest you to use the ROS-Industrial source: https://github.com/ros-industrial/robotiq   If you think there is an alternative driver that supersedes the one provided there, then I'd also suggest to let ROS-I know about it, as there is more people watching there.

    I connect the gripper to Linx via the USB of the gripper and camera supplied by robotiq company. 
    There you mention that you have gripper and camera. As far as I know, the camera is still not supported in ROS, and having the gripper mounted on the camera and then connecting a single USB cable is not well supported in ROS either. Check this thread for more info about it: http://dof.robotiq.com/discussion/comment/1271 
  • carlosjosergcarlosjoserg Posts: 18Tactile Sensor Beta Testers Handy
    Nevertheless, the error you have in the screen is about no ROS master running, you need to run
    roscore
      in a different terminal
  • wukongwukong Posts: 3 Apprentice
    Thanks for your answer. Actually I have run the roscore, the problem I met is "can't open commport to the ttyUSB0", just the last line as the terminal shown. And I do have the gripper mounted on the camera and connect to PC using the single USB of the camera,as you said, maybe the problem is here. Anyway, I will find other solutions to solve it. Thanks again.
Sign In or Register to comment.
Left ArrowBack to discussions page